阿里云盾控制台 WordPress IP验证不当漏洞 解决方法

WordPress IP验证不当漏洞

阿里云盾控制台漏洞提示wordpress IP验证不当漏洞,简介内容如下:wordpress /wp-includes/http.php文件中的wp_http_validate_url函数对输入IP验证不当,导致黑客可构造类似于012.10.10.10这样的畸形IP绕过验证,进行SSRF。

WordPress IP验证不当漏洞

关于wordpress IP验证不当漏洞的解决办法,首先我们需要把wordpress升级到最新版本。

[mark_b]这里非常的有必要提醒下:

请到wordpress国际站下载最新版: https://wordpress.org/download

而不是wordpress中文官网(https://cn.wordpress.org/download/)

因为种种原因,wordpress中文官网的版本会比国际站的更新慢好几个月。

比如现在wordpress国际站的版本已经是5.1.1了,而中文站的版本是5.0.3

如下图;整整慢了四个版本…

wordpress 历史版本

[/mark_b]

然后做以下的修复操作即可。

http.php

 

1、打开/wp-includes/http.php文件,在546行左右找到:

  1. $same_host = strtolower$parsed_home[‘host’] ) === strtolower$parsed_url[‘host’] );

将其替换成:

  1. $same_host = (strtolower($parsed_home[‘host’]) === strtolower($parsed_url[‘host’]) || ‘localhost’ === strtolower($parsed_url[‘host’]));

 

2、在文件大约563行左右找到:

  1. if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0]

将其替换成:

  1. if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0] || 0 === $parts[0]

修改完以上内容,再到阿里云盾控制台重新验证一下漏洞,就会发现漏洞已经不存在了。

原创文章,作者:老D,如若转载,请注明出处:https://laod.cn/security/wordpress-ip-http.html

(1)
上一篇 2019-04-03 17:19
下一篇 2019-04-18 14:43

相关推荐

发表评论

登录后才能评论